Jump to content

Bubble blaster pump rusting?


titus'reef
 Share

Recommended Posts

I have a BB 3000 and the impeller shaft cracked and corroded after 10 months, they replaced the pump. The third picture shows the screws, those are not the same as mine, stainless steel. It looks like the rust is coming from the screws

Link to comment
Share on other sites

After a week of using the new skimmer I notice the screws rusting.So I called them right away and I had the new screws within 5 days. Well,... a month later after the new screws were in use I notices the metal around the screws was rusted and not the titanium screws. So this time wasn't the screws. I just home the new pump they sent me will not rust. lol

Link to comment
Share on other sites

I am showing some of the same rusting pattern in my BB300. It is about 6 months old and in use for about a month or so. The small amount of rust should be OK for SPS IMHO. There is a small, knurled nut insert in the volute which may be the problem in my case. The SS insert in the motor body has some staining on it as well as the screw. I think that it may be transferred from the volute nut.

Link to comment
Share on other sites

Hey Algae, your looks like what mine looked like when I took it out a month or so ago... Altough I had a bit more rust on the actual pump part, but my screws looked the same.

 

What was yours from? What did bubble blaster replace?

 

I guess this is another chore I have to do tomorrow, need to pull the pump out and see if it is worse and give them a call!

Link to comment
Share on other sites

Oops sorry mine doesn't count, I assume all these are in sump, mine is external. They do have good customer service, I got the RA# and boxed it up, she said they have a good turn around time once they receive it then I remembered I was leaving the following monday for a week, I called back to order another pump, I would keep it as a back up, but she said based on the serial# she would ship me a pump that day, it arrived on that Saturday so I had it up and running before I left

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...