Jump to content
Sign in to follow this  
CrazyInside

Fritz RPM Pro salt vs trident

Recommended Posts

I’ve been using fritz for awhile now and love it. Opened a new box this weekend and did a water change on the tank with it. The alk is suppose to be 8.5 when mixed up. Well after a 20 gallon water change my alk dropped a fair bit, alk and calcium should have gone up.

Ill have to make up a 5 gallon bucket and test it tonight to see what’s up. 

You can see where I changed the water, it tested and immediately kicked the doser on  

 

 

 

 

E71B4692-6E79-48AF-9DD9-AEA5824FD1C3.jpeg

  • Sad 1

Share this post


Link to post
Share on other sites

That is disturbing.  Would have to be a significant difference for a 20% change to bring the setpoint down that far unless something else funky was going on.  Does everything look OK?

Share this post


Link to post
Share on other sites

Do you have a manual alk test kit to see what the new saltwater reads?

Share this post


Link to post
Share on other sites
1 hour ago, SuncrestReef said:

Do you have a manual alk test kit to see what the new saltwater reads?

I do, I’ll make up some new water tonight and test it tomorrow morning. 

Share this post


Link to post
Share on other sites
2 hours ago, albertareef said:

That is disturbing.  Would have to be a significant difference for a 20% change to bring the setpoint down that far unless something else funky was going on.  Does everything look OK?

Everything in the tank looks fine, saw nothing weird until the trident did it’s testing and sent me an alert. Will be interesting to test a fresh batch tonight

Share this post


Link to post
Share on other sites

I'm going to follow this, i mixed 40g the other day from an older box of fritz and it came out at about 5.3 alk

Share this post


Link to post
Share on other sites
13 minutes ago, ChrisQ said:

I'm going to follow this, i mixed 40g the other day from an older box of fritz and it came out at about 5.3 alk

I have a feeling this is what I’m going to find. I’ve never had an issue with this salt and this was the first batch from a new box. 

Share this post


Link to post
Share on other sites
Posted (edited)
53 minutes ago, CrazyInside said:

I have a feeling this is what I’m going to find. I’ve never had an issue with this salt and this was the first batch from a new box. 

Kinda bummed, i just bought a fresh box couple days ago, haven't opened it yet but im going to and ill also run some tests.

 

edit: We're talking about blue boxes right? Not red.

 

 

 

 

Edited by ChrisQ

Share this post


Link to post
Share on other sites
I mixed up a fresh batch of Red Sea Coral Pro today and tested it for alkalinity and calcium:
 
Alk = 9.7 dKH
Cal = 420 ppm

Share this post


Link to post
Share on other sites

I use fritz blue box and just tested the batch I mixed over the weekend at 8.0 dKH. That's usually what I see. I bought from seahorse a couple of weeks ago. Maybe you got low batch?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
3 hours ago, CrazyInside said:

I have a feeling this is what I’m going to find. I’ve never had an issue with this salt and this was the first batch from a new box. 

This might be a dumb question, but did you double-check the salinity of the new water?  Is it possible you didn't add enough salt mix into the water, causing the lower alk as well as lower salinity?  Just trying to rule out another variable.

Share this post


Link to post
Share on other sites
Posted (edited)
41 minutes ago, SuncrestReef said:

This might be a dumb question, but did you double-check the salinity of the new water?  Is it possible you didn't add enough salt mix into the water, causing the lower alk as well as lower salinity?  Just trying to rule out another variable.

Didn’t have lower salinity, always check with a refractometer. 

 

And for an update to this I just mixed up a fresh 5 gallon and got 5.9alk with sailfert test kit. Looks like I got a bad batch. 

3 hours ago, ChrisQ said:

Kinda bummed, i just bought a fresh box couple days ago, haven't opened it yet but im going to and ill also run some tests.

 

edit: We're talking about blue boxes right? Not red.

 

 

 

 

Yes blue box, tested new batch at 5.9. 

 

On the plus side, already digging the trident for these random mishaps. I’ve used rpm forever without issues, it just happened to catch one bad batch. So that’s a win in my book 👍😁

Edited by CrazyInside
  • Like 3

Share this post


Link to post
Share on other sites

Yet another example of how useful the Trident can be!  How long do you think it would have taken you to discover this drop in alk without it?  

A few weeks ago I had a big drop in alkalinity after I changed out the GFO media in my reactor, and the Trident revealed this within a couple hours.  Before this, I never knew GFO impacted alkalinity.

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, SuncrestReef said:

Yet another example of how useful the Trident can be!  How long do you think it would have taken you to discover this drop in alk without it?  

A few weeks ago I had a big drop in alkalinity after I changed out the GFO media in my reactor, and the Trident revealed this within a couple hours.  Before this, I never knew GFO impacted alkalinity.

Well I made sure to get a trident on release day because I’m lazy with testing... so either this weekend during maintenance time or when stuff looked pissed off and I decided to test haha. 

I got my dos hooked up and running so it’s already fixing the tank for me which is nice. The calcium and mag tested fine on the new batch so I’ll just add a bit of alk buffer to my water changes until I get through this box. 

Truthfully I think apex and their trident is single handily going to keep my sps alive/growing 😂 

  • Like 1

Share this post


Link to post
Share on other sites

Out of all the salts I’ve tried of my 10yrs reefing. The fritz mixes ok but leaves my brute can orange. Even worse than the original instant ocean. Just my opinion

Share this post


Link to post
Share on other sites
33 minutes ago, Trailermann said:

I use the Fritz so am interested in you test results.

I posted them above. Tested at 5.9

Share this post


Link to post
Share on other sites
8 minutes ago, CrazyInside said:

I posted them above. Tested at 5.9

Very odd.  Is there a batch number or other identifier such that this could be reported back to the company?  Just seems way off from what their target likely is and, obviously, what your prior experience indicates.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...