Jump to content
River City Corals

Ricordia growout thread (pictures and system set up)

Recommended Posts

Ok guys and gals this will be the thread to post your first pics and system specs. Need to have this done by November 12th or you will be disqualified. Rules were already posted in the original grow out comp thread. Some people have yet to pay or pic up. Please contact me asap if this is an issue. I will start this party off with my first post.

Share this post


Link to post
Share on other sites

Ok ill start this out!! My system is a NUVO im20. It has a ghost skimmer, two filter baskets and i run chemipure blue. I have upgraded the pumps to twin Sicce 258 gph returns with spinstreams on both sides. I run a Cobalt heater And a Smart Hydor ATO. The light i am currently using is an Ocean Revive Arctic T247 with blues at 40% and whites at 3%. The lights comes on at 10:00 snd off at 9 pm.

 

Now onto the pics

e5a0daadb264c08941a556083da2442a.jpg0a3434ccf810bb87a20a97900c045e1c.jpg

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

50 Gallon

Over 2 AI primes Lighting on at 930-730 Ramp at 1hour

Run a sump with a Jabeo Return pump

Tunze ATO

Filter sock with Carbon and Chemi

Heater Eheim (New heater Finnex with controller)

Dose Nothing

Bubble Magnus Skimmer.

Cal 450

Mag 1280

 

C28C1C29-05B0-4331-91BF-B84D7BE1124F_zps

 

 

DE265A65-6645-4551-BCA3-3BDA381D6AE5_zps

Edited by Flash21

Share this post


Link to post
Share on other sites

Tank specs are in my sig. Reef levels are Alk:10dKh, Cal:450, Mag:1440. I have this ricordia growing in my frag tank but both tanks are tied to the same sump and thus share the same water supply. ~140g total volume.

IMG_0522.jpg

IMG_0526.jpg

You can kind of see it but there are 3 green mouths on my frag. It's been eating fauna marin lps pellets.

Edited by youcallmenny

Share this post


Link to post
Share on other sites

My system is a 40b with 15 gal sump. Running rowaphos, roughly 10lbs live rock and asm mini g skimmer in sump. Ecotech 650 gph return pump with wp10 and wp25 for flow in the tank. Tek elite 6 bulb t5 for lighting

6177160474d8926bc5a633dd08488c91.jpg

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

My system is a 40b with 15 gal sump. Running rowaphos, roughly 10lbs live rock and asm mini g skimmer in sump. Ecotech 650 gph return pump with wp10 and wp25 for flow in the tank. Tek elite 6 bulb t5 for lighting 6177160474d8926bc5a633dd08488c91.jpg

Sent from my iPhone using Tapatalk

Looks happy

Share this post


Link to post
Share on other sites

9c6fdee71d08a2ac921abbcd09ff28b3.jpg

0e472df440929ada0753042275aa4e0c.jpg

 

My tank is a 20 gal tall holding tank. Waiting for my 60 gal cube to get delivered.

 

Running a HOB filter with powered and heater. Lights are AI Prime settings are mainly blues with whites at 35 percent they come on at 10am and sunset is 8pm with them set up with a lunar schedule for moonlights

 

Sent from my SM-N920P using Tapatalk

Share this post


Link to post
Share on other sites

9c6fdee71d08a2ac921abbcd09ff28b3.jpg

0e472df440929ada0753042275aa4e0c.jpg

 

My tank is a 20 gal tall holding tank. Waiting for my 60 gal cube to get delivered.

 

Running a HOB filter with powered and heater. Lights are AI Prime settings are mainly blues with whites at 35 percent they come on at 10am and sunset is 8pm with them set up with a lunar schedule for moonlights

 

Sent from my SM-N920P using Tapatalk

Sorry for crappy pics, I broke my lense on back of my phone. I'll hopefully have it fixed by next posting

 

Sent from my SM-N920P using Tapatalk

Share this post


Link to post
Share on other sites

Ok I'll be posting pictures tomorrow. My tank is a 90 gallon. I'm running 6 bulb T5 lights on it. I have two RW-8's running for flow. I dose Ca and KH but I have them off temporarily because if a slight spike. I run a skimmer can't think of the make atm and a reactor for carbon. Anything I'm missing?

 

Oh I also have a JBJ ATO

 

 

Sent from my iPhone using Tapatalk

Edited by wmcbane200

Share this post


Link to post
Share on other sites

grow%20out.jpg

 

Currently in a 29 gal, (23x22.5x12) DIY acrylic cube frag tank, DIY LEDS on 2 timers for white and blue/royal blue, that is hooked up to the 225gal 
DIY Display Tank (60x36x24) and serviced by an 80gal (48x24x16) DIY custom sump.  

 

Controlled by Apex, dual 250w ebo's, ATO, DIY skimmer with 10k bubble blaster, DIY calcium reactor with a modified industrial regulator and DIY Bio-pellet reactor, running UV.

Edited by wanareef

Share this post


Link to post
Share on other sites

This is growing in my daughter's pico tank.

 

8 gallon cube (marineland)

 

Live Rock

 

Small additional powerhead

 

Heater

 

Small DIY 3 LED fixture. See build here:

 

http://www.pnwmas.org/topic/38045-pico-leds-diy/

 

A very simple setup! Here is a FTS after setup:

 

2a6fcc0bfed5715eca186025f42c3830.jpg

 

 

Top off is done once a week with a measuring cup. No water changes to date so far...

 

A sexy shrimp, clown and mini maxi along with few zoas and another ric live with it.

 

81f8964637c820c43246f1f04c5a3d83.jpg

Share this post


Link to post
Share on other sites

Brian Let me get one more. Top post is daughters tank and this one is wife's bedroom tank. I just maintain them.

 

10 Nuvo

Return Pump off 16 Nuvo with Spin head

Dose nothing.

Lighting 2040 OR set to 10-9 set anywhere from 60% blues to 20% whites usually set to 0-10%

Run chemi and phosban media

ATO is smart ATO

 

 

IMG_6908_zpsmh01nvby.jpg

 

IMG_6910_zps70p2yyjd.jpg

Share this post


Link to post
Share on other sites

Well I haven't pick mine up yet from the person that got it for me since I have been busy but I can post hopefully later today but anyways here is my tank break down

 

40 gallon nuvo (cube)

No skimmer

Ai prime at 60% white , 80 %blue , 85% Royale blue , this is at the highest point

Pump what ever came with the nuvo

Share this post


Link to post
Share on other sites

Ok - these are bad shots but best I can get at the moment. Top down is hard.

 

post-15789-0-08839400-1478997915_thumb.jpg

 

post-15789-0-46827700-1478997916_thumb.jpg

 

post-15789-0-79266900-1478965406_thumb.jpg

 

 

 

 

System Info:

-200g (about 220 total volume)

-Radion x30 lighting (Loosely set to their SPS schedule)

-KH: 8 

-Cal: 450

Edited by Bevo5

Share this post


Link to post
Share on other sites

I've been travelling and unable to pick up last week at C & C.   If there's a chance to collect today, I'd love to stay in the contest.  If not, I'll donate my ric to the cause.  Thanks

 

 

 

 

Share this post


Link to post
Share on other sites

ea458437a53dbcd355e41171a5cfec82.jpge58e47424e0d51d8e017854e69012618.jpg

I'm running a 20 gallon IM fusion tank.

I have the AI Prime light @30%, a tunze nano skimmer, chemipure elite in the back. ATO when it works right. I do 5 gallon water changes every other weekend (Kent salt).

I'd estimate there's 30# of live rock.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

This is growing in my daughter's pico tank.

8 gallon cube (marineland)

Live Rock

Small additional powerhead

Heater

Small DIY 3 LED fixture. See build here:http://www.pnwmas.org/topic/38045-pico-leds-diy/

A very simple setup! Here is a FTS after setup:2a6fcc0bfed5715eca186025f42c3830.jpg

Top off is done once a week with a measuring cup. No water changes to date so far...

A sexy shrimp, clown and mini maxi along with few zoas and another ric live with it.81f8964637c820c43246f1f04c5a3d83.jpg

Jeremy can you add a profile pic

  • Like 1

Share this post


Link to post
Share on other sites

Ok I'll be posting pictures tomorrow. My tank is a 90 gallon. I'm running 6 bulb T5 lights on it. I have two RW-8's running for flow. I dose Ca and KH but I have them off temporarily because if a slight spike. I run a skimmer can't think of the make atm and a reactor for carbon. Anything I'm missing?

 

Oh I also have a JBJ ATO

 

 

Sent from my iPhone using Tapatalk

295f2b1e1202e1f13b0d293e1fa1abdd.jpg

 

600c0d56f13114bf872d6515dba72606.jpg

 

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×